Pubblicato da: trequattrocinque | 30 dicembre 2010

Giochiamo con iplozero

Ecco a voi un nuovo programma, creato dal mio professore di Matematica elementare da un punto di vista superiore (A).

Si chiama iplozero: permette di disegnare geometricamente in base a dei comandi che noi predisponiamo. Chiaramente non è subito accessibile, pur non essendo difficile, occorre conoscere alcuni comandi con le loro abbreviazioni, per poter dare delle precise consegne al programma.

Vi sono tre finestre: una su cui fare il disegno, una per dare imput ai nostri comandi, infine abbiamo una pagina bianca che può servirci come blocchetto per appunti.

La figura principale che presenta iplozero è la tartaruga (che possiede la forma di un triangolo).

Attraverso essa noi ci spostiamo, se desideriamo tracciare una linea basta dare il comando “giu la penna” (o solo “giu”) dando indicazioni precise di quanto vorremmo farla camminare, mentre se preferiamo non lasciare tracce sul foglio occorre scrivere “su la penna” ( o solo “su”).

Vi sono poi molti atri comandi: il primo che bisogna dare è quello di “pulisci schermo” o anche solo ps.

La tarta può anche andare indietro, anche solo con il comando abbreviato i.

Ad ogni comando però, non bisogna dimenticare di aggiungere sempre di quanti passi vogliamo si sposti. Tra la direzione (destra, indietro, avanti) e il numero di passi dobbiamo lasaciare uno spazio bianco.

Se vogliamo fare un quadrato possiamo abbreviare la procedura scrivendo semplicemente:

ripeti 4 [avanti 100 destra 90]

oppure solamente

ripeti 4 [a 100 d 90]

100 starà a significare il lato del nostro quadrato, mentre 90 lo spostamento che ogni volta dovrà fare la tarta (tartaruga) cioè l’ampiezza dell’angolo retto.

Se vogliamo ripartire dal punto d’inizio riposizionando la tarta basta dare il comando “tana”.

Per salvare il nostro capolavoro finale basta scrivere:

tartaconserva “nomelavoro.BMP

Ora vi mostro una semplice casetta realizzata appunto con iplozero.

Annunci

Rispondi

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...

Categorie

%d blogger hanno fatto clic su Mi Piace per questo: